[SOLVED] Product Import - Urgent help please

I'm trying to import a csv file and it is not working I get the following error every time.

Choose a checkout type

There is no mention of checkout type in the fields, have I missed something earlier on? desperately need to get this up and running to show the client before they go on holiday tomorrow.

Thanks, Colin

P.S. this even happens with 1 item in the csv file 


  • 6 Comments sorted by
  • Vote Up0Vote Down
    Interestingly I just tried to import the sample file and I get the same result

    Choose a checkout type
    Choose a checkout type
    Choose a checkout type

    Something seems to be not functioning correctly, the checkout type is an option for each product I assume having looked at the product page.

    Choose the way customers will checkout with this product.
    But there is clearly no option to apply a field for the checkout type in the import page.

  • Vote Up0Vote Down
    And I just tried it on a second shop installation and had the same result.
  • Vote Up0Vote Down
    Thank you for your post, Colin.

    We are testing this on our side and will post back here shortly with a solution.

    Thank you for your patience in this matter.
  • Vote Up0Vote Down
    We found the problem, it occurred in version it seems.

    To resolve the problem, there are 2 options:

    1. Open the "wp-checkout/models/product.php" file and on about line #1014 add 'checkout_type' => 'regular' to the defaults array like this: http://screencast.com/t/b4Kpr4jm

    2. Submit a ticket to our helpdesk so that we can send you a new development build to solve this since we have fixed it now in our latest development: http://tribulant.com/support/
  • Vote Up0Vote Down
    Thanks, thought it seemed like a small code error, I managed a work around for the client using an older version of the software but will make the suggested change and try the latest version again.
  • Vote Up0Vote Down
    Thank you for your response, Colin.

    Great, no problem, I'm glad that you got it resolved your way.

    As always, it is recommended to use the latest version (despite this problem).
    When you have time, please try out the change in the latest version and post back here to let me know if everything is in order and so that other users with this problem can apply it as well.

    All the best
Sign In or Register to comment.