[Solved] hardcoded call to slideshow is showing multiple galleries

edited July 2015 in Slideshow Gallery plugin

I have been using slideshow gallery to display the banner photos at http://steeplechasers.org (gallery_id 1). This has worked fine until I added another gallery for a different purpose (gallery id 2, see http://steeplechasers.org/membership/shirt-sale-august-2015/).

Now the following code displays both galleries. (maybe interesting that[tribulant_slideshow gallery_id="2" autoheight="true"] only displays the 2nd gallery)

slideshow(true, null, false, array('layout' => 'responsive',
'auto' => 'true',
'gallery_id' => '1',
'showthumbs' => 'false',
'autospeed' => '6',
'orderby' => 'random',
'fadespeed' => '10',
'showinfo' => 'false'));


  • 6 Comments sorted by
  • Vote Up0Vote Down

    forgot (again) to post that this is slideshow gallery 1.5.3

    BTW - this is cross posted from the wordpress support page, as I hadn't read the sticky post first

  • Vote Up0Vote Down

    sorry the code was escape quoted -- I did cut/paste from the wordpress posting

    and before you ask, I verified the slides which are being displayed in the banner incorrecty are not tagged as part of both galleries. I verified this using manage galeries > order slides -- the slides in question are not included in gallery id 1 (for the banner)

  • Vote Up0Vote Down
    edited July 2015

    Hello Lou,

    Thank you for getting in contact with us.

    Will you please replace the problematic code with the following:

    <?php echo do_shortcode('[tribulant_slideshow gallery_id="1" layout="responsive" auto="true" showthumbs="false" autospeed="6" orderby="random" fadespeed="10" showinfo="false"]'); ?>
    and let us know if it helps?

    We`ll look forward to your response.

    All the best!

  • Vote Up0Vote Down

    Well, it gets rid of the unexpected images, but the behavior changed a bit. I had to modify my css slightly as I was depending slideshow-wrappercustom id rather than the slideshow-wrapper class, but that solved the problem.

    Seems like this might be a bug, but thanks for the recommendation for this workaround.

  • Vote Up0Vote Down

    I don't see any way to edit my topic to add [solved] to the beginning of the title.

  • Vote Up0Vote Down

    Hello @Lou,

    Thank you for your response.

    I`m glad to hear that it worked for you, we`ll investigate the issue you described to see if we can find the problem.

    Please feel free to get in touch if you need further assistance.

    All the best!

This discussion has been closed.