[Solved] Issue with recent update

Took the recent checkout upgrade to 1.9 and some coupon issues still persist.

1. When applying coupon discount now works and end user no longer gets the "7" pop up box but the screen flashes a mysql error before it refreshes and applies the coupon. Goes so fast, can not really ascertain the error but it has scared off a few users.

2. If I add say an item to the cart, apply the discount and then decide to delete the item from the cart, an error is generated saying that deleting the item would create a total smaller than 0. It asks to have the user delete the coupon first, but there is no such link anymore to remove the coupon and the end user becomes stuck unable to clear the cart.

Test out at http://www.danceboxoffice.com/?page_id=764
Coupon Code: 2723D092B638
Quantity Code which deducts $1.90 per item basically zeroing out the shipping cost


  • 6 Comments sorted by
  • Vote Up0Vote Down
    @"Steven Weisz"

    You can click escape to see the mysql errors. Here's a screenshot of your errors: http://www.screencast.com/t/GxFuWKeH

    Warning: mysql_real_escape_string(): Access denied for user 'dancebox'@'localhost' (using password: NO) in /home/dancebox/public_html/wp-content/plugins/wp-checkout/wp-checkout.php on line 1892

    Warning: mysql_real_escape_string(): A link to the server could not be established in /home/dancebox/public_html/wp-content/plugins/wp-checkout/wp-checkout.php on line 1892

    Please check your permissions for your user on your server?

  • Vote Up0Vote Down
    /wp-checkout is 755
    /wp-checkout/wp-checkout.php is 644
    Please advise if this should be different but this has not changed with the update
  • Vote Up0Vote Down
    Isn't the issue here that mysql_real_escape_string() is deprecated?? Also, the globals are defined in wp-config.php for connecting to the server and they work fine! Seems the code needs updating.
  • Vote Up0Vote Down
    @"Steven Weisz"

    Thank you for your response on this.

    Regarding the issues:

    1. Yes, mysql_real_escape_string() was the cause of the issue. Using that function tries to use the current, active MySQL connection which in this case may not exist due to the way that WordPress makes it's own connection. We have now replaced this function with esc_sql() and esc_html() in the code where needed in our latest development.

    2. I am not able to duplicate this error saying that the total will be smaller than zero. I added the item to the cart, applied the coupon code and then deleted the item and it worked. Is there a different procedure I can follow to duplicate it?

    I look forward to your response.
  • Vote Up0Vote Down
    @"Steven Weisz"

    I hope you are doing well.

    We discussed these 2 things with you in our help desk.

    1. This is resolved by an update of our Shopping Cart plugin to version 1.9.1 which was released today.

    2. We will release an update for our Advanced Coupons extension plugin for the Shopping Cart plugin to address this. I sent you a new build/version with a solution in our help desk.
  • Vote Up0Vote Down
    SOLVED - Upgrading to 1.9.1 solves mysql errors and new build of advanced coupons solved the second issue. All is working as it should now.
  • Vote Up0Vote Down
    @"Steven Weisz"

    Thank you for your response and for letting me know, Steven.

    I'm glad to hear that things are working as they should.

    We are working on a few more things for the Checkout - Advanced Coupons extension plugin then we will release an update for it accordingly.

    I'll mark this as [Solved] if that's okay.
Sign In or Register to comment.